import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}$";
final String string = "# All POS codes should be 2 digits\n"
+ "# NOTE: Single digits should have a leading 0\n"
+ "# It's possible data loading might drop this! This regex would therefore fail\n"
+ "# This regex will also match codes that are currently unassigned\n"
+ "# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets\n"
+ "01\n"
+ "04\n"
+ "10\n"
+ "55\n"
+ "99\n"
+ "# Checks\n"
+ "0A\n"
+ "1\n"
+ "9\n"
+ "A0\n"
+ "--\n"
+ "990\n"
+ "010\n"
+ "**\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}