import Foundation
let pattern = #"^\d{2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
# All POS codes should be 2 digits
# NOTE: Single digits should have a leading 0
# It's possible data loading might drop this! This regex would therefore fail
# This regex will also match codes that are currently unassigned
# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets
01
04
10
55
99
# Checks
0A
1
9
A0
--
990
010
**
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)