using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{2}$";
string input = @"# All POS codes should be 2 digits
# NOTE: Single digits should have a leading 0
# It's possible data loading might drop this! This regex would therefore fail
# This regex will also match codes that are currently unassigned
# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets
01
04
10
55
99
# Checks
0A
1
9
A0
--
990
010
**
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}