re = /^\d{2}$/m
str = '# All POS codes should be 2 digits
# NOTE: Single digits should have a leading 0
# It\'s possible data loading might drop this! This regex would therefore fail
# This regex will also match codes that are currently unassigned
# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets
01
04
10
55
99
# Checks
0A
1
9
A0
--
990
010
**
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end