use strict;
my $str = '# All POS codes should be 2 digits
# NOTE: Single digits should have a leading 0
# It\'s possible data loading might drop this! This regex would therefore fail
# This regex will also match codes that are currently unassigned
# - https://www.cms.gov/medicare/coding-billing/place-of-service-codes/code-sets
01
04
10
55
99
# Checks
0A
1
9
A0
--
990
010
**
';
my $regex = qr/^\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}