# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\n]*\n)[^\n]*\n/$1/gm;t' <<< "Line 1
Line 2
Line 3
Line 4"