import re
regex = re.compile(r"([^\n]*\n)[^\n]*\n", flags=re.MULTILINE)
test_str = ("Line 1\n"
"Line 2\n"
"Line 3\n"
"Line 4")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)