use strict;
my $str = 'Line 1
Line 2
Line 3
Line 4';
my $regex = qr/([^\n]*\n)[^\n]*\n/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";