# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#{3}(?P<town>.*?)(@{3}\n.*?)(&{3}(?P<person>.*?)(\^{3}\n))+?/\g<person> is from \g<town>\n/gms;t' <<< "STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT"