import Foundation
let pattern = ##"#{3}(?P<town>.*?)(@{3}\n.*?)(&{3}(?P<person>.*?)(\^{3}\n))+?"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ####"""
STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<person> is from \g<town>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)