use strict;
my $str = 'STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT';
my $regex = qr/#{3}(?P<town>.*?)(@{3}\n.*?)(&{3}(?P<person>.*?)(\^{3}\n))+?/msp;
my $subst = '\\g<person> is from \\g<town>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";