// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)#{3}(?P<town>.*?)(@{3}\n.*?)(&{3}(?P<person>.*?)(\^{3}\n))+?").unwrap();
let string = "STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT";
let substitution = "\\g<person> is from \\g<town>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}