const regex = new RegExp('#{3}(?P<town>.*?)(@{3}\\n.*?)(&{3}(?P<person>.*?)(\\^{3}\\n))+?', 'gms')
const str = `STARTOFTEXT
&&&Aragorn^^^
###The Shire@@@
&&&Frodo^^^
&&&Bilbo^^^
&&&Pippin^^^
###Gondor@@@
&&&Faramir^^^
&&&Boramir^^^
ENDOFTEXT`;
const subst = `\g<person> is from \g<town>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);