package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\]|\[.+?\]|$`)
var str = `[]
[34143432]
dsadsad[343]43342dasdsad
dasdsada[]32eq3eq3[]ewaewq
qweqwe[342dsa]342423423343[]dsada
dasdsadsadsa[]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}