re = /\[\]|\[.+?\]|$/
str = '[]
[34143432]
dsadsad[343]43342dasdsad
dasdsada[]32eq3eq3[]ewaewq
qweqwe[342dsa]342423423343[]dsada
dasdsadsadsa[]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end