import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\]|\\[.+?\\]|$";
final String string = "[]\n"
+ "[34143432]\n"
+ "dsadsad[343]43342dasdsad\n"
+ "dasdsada[]32eq3eq3[]ewaewq\n"
+ "qweqwe[342dsa]342423423343[]dsada\n"
+ "dasdsadsadsa[]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}