const regex = /(\p{L}\p{M}*+)-\h(?=\p{L})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\p{L}\\p{M}*+)-\\h(?=\\p{L})', 'gm')
const str = `the sun was shin- ing and the sky bl- ue`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);