use strict;
my $str = 'the sun was shin- ing and the sky bl- ue';
my $regex = qr/(\p{L}\p{M}*+)-\h(?=\p{L})/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";