re = /(\p{L}\p{M}*+)-\h(?=\p{L})/m
str = 'the sun was shin- ing and the sky bl- ue'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result