$re = '/(\p{L}\p{M}*+)-\h(?=\p{L})/m';
$str = 'the sun was shin- ing and the sky bl- ue';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;