#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(biovar)? *(?P<number>\d+)?[, ]*(?P<addition>\w+)?"
Local $sString = "biovar 1" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 3" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"6" & @CRLF & _
"7" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"6" & @CRLF & _
"3" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"4" & @CRLF & _
"2" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"?" & @CRLF & _
"6" & @CRLF & _
"6" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"?" & @CRLF & _
"3" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"3" & @CRLF & _
"?" & @CRLF & _
"2" & @CRLF & _
"2" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"2" & @CRLF & _
"9" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"4" & @CRLF & _
"3" & @CRLF & _
"5" & @CRLF & _
"5" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"9" & @CRLF & _
"6" & @CRLF & _
"2" & @CRLF & _
"?" & @CRLF & _
"6" & @CRLF & _
"3" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"?" & @CRLF & _
"3" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"3" & @CRLF & _
"2" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"2" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"2" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1a" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1a" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 2" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"6" & @CRLF & _
"6" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 3" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"4" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"2, atypical" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1, atypical" & @CRLF & _
"4" & @CRLF & _
"2" & @CRLF & _
"2" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"1" & @CRLF & _
"3b" & @CRLF & _
"4" & @CRLF & _
"2" & @CRLF & _
"7" & @CRLF & _
"7" & @CRLF & _
"6" & @CRLF & _
"9" & @CRLF & _
"7" & @CRLF & _
"7" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"1" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 3" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 3" & @CRLF & _
"biovar 3" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 3" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"?" & @CRLF & _
"biovar Abortus" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 2" & @CRLF & _
"?" & @CRLF & _
"biovar 3" & @CRLF & _
"biovar 4" & @CRLF & _
"?" & @CRLF & _
"biovar 5" & @CRLF & _
"biovar 6" & @CRLF & _
"?" & @CRLF & _
"biovar 9" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 2" & @CRLF & _
"?" & @CRLF & _
"biovar 3" & @CRLF & _
"?" & @CRLF & _
"biovar 3" & @CRLF & _
"?" & @CRLF & _
"biovar 4" & @CRLF & _
"?" & @CRLF & _
"biovar 5" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"biovar I" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 4" & @CRLF & _
"biovar 3" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 1" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"biovar 2" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?" & @CRLF & _
"?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")