import Foundation
let pattern = #"(biovar)? *(?P<number>\d+)?[, ]*(?P<addition>\w+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
biovar 1
?
biovar 1
biovar 1
biovar 1
biovar 3
1
1
1
1
1
1
1
1
?
?
?
?
?
?
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
3
3
6
7
1
1
1
3
3
6
3
?
1
1
4
2
1
1
1
1
3
3
3
1
1
9
?
6
6
1
2
1
1
?
3
1
1
3
1
2
1
1
1
3
3
3
?
2
2
?
?
?
?
?
?
2
9
?
?
4
3
5
5
?
1
9
6
2
?
6
3
1
1
?
3
?
1
3
2
?
1
1
1
?
?
?
?
?
?
2
?
?
?
?
?
2
?
?
?
biovar 1
?
biovar 1
biovar 1
biovar 1a
biovar 1
biovar 1a
?
?
?
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 2
?
?
?
6
6
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 3
biovar 1
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
4
?
1
1
2, atypical
1
1
1
1
1
1
1, atypical
4
2
2
1
1
1
1
1
1
1
3b
4
2
7
7
6
9
7
7
?
?
1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 1
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
biovar 3
?
?
?
?
?
?
?
biovar 3
biovar 3
biovar 1
biovar 1
biovar 1
biovar 3
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
?
biovar Abortus
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 2
?
biovar 3
biovar 4
?
biovar 5
biovar 6
?
biovar 9
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 2
?
biovar 3
?
biovar 3
?
biovar 4
?
biovar 5
?
?
?
?
biovar I
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 3
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
?
?
?
?
?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)