import re
regex = re.compile(r"(biovar)? *(?P<number>\d+)?[, ]*(?P<addition>\w+)?")
test_str = ("biovar 1\n"
"?\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 3\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"3\n"
"3\n"
"6\n"
"7\n"
"1\n"
"1\n"
"1\n"
"3\n"
"3\n"
"6\n"
"3\n"
"?\n"
"1\n"
"1\n"
"4\n"
"2\n"
"1\n"
"1\n"
"1\n"
"1\n"
"3\n"
"3\n"
"3\n"
"1\n"
"1\n"
"9\n"
"?\n"
"6\n"
"6\n"
"1\n"
"2\n"
"1\n"
"1\n"
"?\n"
"3\n"
"1\n"
"1\n"
"3\n"
"1\n"
"2\n"
"1\n"
"1\n"
"1\n"
"3\n"
"3\n"
"3\n"
"?\n"
"2\n"
"2\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"2\n"
"9\n"
"?\n"
"?\n"
"4\n"
"3\n"
"5\n"
"5\n"
"?\n"
"1\n"
"9\n"
"6\n"
"2\n"
"?\n"
"6\n"
"3\n"
"1\n"
"1\n"
"?\n"
"3\n"
"?\n"
"1\n"
"3\n"
"2\n"
"?\n"
"1\n"
"1\n"
"1\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"2\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"2\n"
"?\n"
"?\n"
"?\n"
"biovar 1\n"
"?\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1a\n"
"biovar 1\n"
"biovar 1a\n"
"?\n"
"?\n"
"?\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 2\n"
"?\n"
"?\n"
"?\n"
"6\n"
"6\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 3\n"
"biovar 1\n"
"biovar 1\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"4\n"
"?\n"
"1\n"
"1\n"
"2, atypical\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1, atypical\n"
"4\n"
"2\n"
"2\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"1\n"
"3b\n"
"4\n"
"2\n"
"7\n"
"7\n"
"6\n"
"9\n"
"7\n"
"7\n"
"?\n"
"?\n"
"1\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 1\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 3\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 3\n"
"biovar 3\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 3\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"?\n"
"biovar Abortus\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 2\n"
"?\n"
"biovar 3\n"
"biovar 4\n"
"?\n"
"biovar 5\n"
"biovar 6\n"
"?\n"
"biovar 9\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar 1\n"
"biovar 2\n"
"?\n"
"biovar 3\n"
"?\n"
"biovar 3\n"
"?\n"
"biovar 4\n"
"?\n"
"biovar 5\n"
"?\n"
"?\n"
"?\n"
"?\n"
"biovar I\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 4\n"
"biovar 3\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 1\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"biovar 2\n"
"?\n"
"?\n"
"?\n"
"?\n"
"?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")