using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(biovar)? *(?P<number>\d+)?[, ]*(?P<addition>\w+)?";
string input = @"biovar 1
?
biovar 1
biovar 1
biovar 1
biovar 3
1
1
1
1
1
1
1
1
?
?
?
?
?
?
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
3
3
6
7
1
1
1
3
3
6
3
?
1
1
4
2
1
1
1
1
3
3
3
1
1
9
?
6
6
1
2
1
1
?
3
1
1
3
1
2
1
1
1
3
3
3
?
2
2
?
?
?
?
?
?
2
9
?
?
4
3
5
5
?
1
9
6
2
?
6
3
1
1
?
3
?
1
3
2
?
1
1
1
?
?
?
?
?
?
2
?
?
?
?
?
2
?
?
?
biovar 1
?
biovar 1
biovar 1
biovar 1a
biovar 1
biovar 1a
?
?
?
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 2
?
?
?
6
6
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 3
biovar 1
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
4
?
1
1
2, atypical
1
1
1
1
1
1
1, atypical
4
2
2
1
1
1
1
1
1
1
3b
4
2
7
7
6
9
7
7
?
?
1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 1
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
biovar 3
?
?
?
?
?
?
?
biovar 3
biovar 3
biovar 1
biovar 1
biovar 1
biovar 3
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
?
biovar Abortus
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 2
?
biovar 3
biovar 4
?
biovar 5
biovar 6
?
biovar 9
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 2
?
biovar 3
?
biovar 3
?
biovar 4
?
biovar 5
?
?
?
?
biovar I
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 3
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
?
?
?
?
?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}