use strict;
my $str = 'biovar 1
?
biovar 1
biovar 1
biovar 1
biovar 3
1
1
1
1
1
1
1
1
?
?
?
?
?
?
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
1
3
3
6
7
1
1
1
3
3
6
3
?
1
1
4
2
1
1
1
1
3
3
3
1
1
9
?
6
6
1
2
1
1
?
3
1
1
3
1
2
1
1
1
3
3
3
?
2
2
?
?
?
?
?
?
2
9
?
?
4
3
5
5
?
1
9
6
2
?
6
3
1
1
?
3
?
1
3
2
?
1
1
1
?
?
?
?
?
?
2
?
?
?
?
?
2
?
?
?
biovar 1
?
biovar 1
biovar 1
biovar 1a
biovar 1
biovar 1a
?
?
?
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 2
?
?
?
6
6
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 3
biovar 1
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
4
?
1
1
2, atypical
1
1
1
1
1
1
1, atypical
4
2
2
1
1
1
1
1
1
1
3b
4
2
7
7
6
9
7
7
?
?
1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 1
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
?
?
?
?
?
?
?
?
?
?
?
?
biovar 3
?
?
?
?
?
?
?
biovar 3
biovar 3
biovar 1
biovar 1
biovar 1
biovar 3
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
?
biovar Abortus
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 2
?
biovar 3
biovar 4
?
biovar 5
biovar 6
?
biovar 9
?
?
?
?
?
?
?
?
?
?
?
?
?
biovar 1
biovar 2
?
biovar 3
?
biovar 3
?
biovar 4
?
biovar 5
?
?
?
?
biovar I
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 4
biovar 3
biovar 1
biovar 1
biovar 1
biovar 1
biovar 1
biovar 2
biovar 2
biovar 2
biovar 2
biovar 2
?
?
?
?
?';
my $regex = qr/(biovar)? *(?P<number>\d+)?[, ]*(?P<addition>\w+)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}