#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miDJ)<style([\S\s]*?)>([\S\s]*?)<\/style>"
Local $sString = "<style>" & @CRLF & _
" .something1 {" & @CRLF & _
" display: flex;" & @CRLF & _
" color: red;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" .something2 { display: flex; }" & @CRLF & _
"</style>" & @CRLF & _
"" & @CRLF & _
"<div>cat</div>" & @CRLF & _
"" & @CRLF & _
"<style>" & @CRLF & _
" .something3 {" & @CRLF & _
" display: flex;" & @CRLF & _
" color: red;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" .something4 { display: flex; }" & @CRLF & _
"</style>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")