re = /<style([\S\s]*?)>([\S\s]*?)<\/style>/mi
str = '<style>
.something1 {
display: flex;
color: red;
}
.something2 { display: flex; }
</style>
<div>cat</div>
<style>
.something3 {
display: flex;
color: red;
}
.something4 { display: flex; }
</style>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end