package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<style([\S\s]*?)>([\S\s]*?)<\/style>`)
var str = `<style>
.something1 {
display: flex;
color: red;
}
.something2 { display: flex; }
</style>
<div>cat</div>
<style>
.something3 {
display: flex;
color: red;
}
.something4 { display: flex; }
</style>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}