import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<style([\\S\\s]*?)>([\\S\\s]*?)<\\/style>";
final String string = "<style>\n"
+ " .something1 {\n"
+ " display: flex;\n"
+ " color: red;\n"
+ " }\n\n"
+ " .something2 { display: flex; }\n"
+ "</style>\n\n"
+ "<div>cat</div>\n\n"
+ "<style>\n"
+ " .something3 {\n"
+ " display: flex;\n"
+ " color: red;\n"
+ " }\n\n"
+ " .something4 { display: flex; }\n"
+ "</style>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}