const regex = /<style([\S\s]*?)>([\S\s]*?)<\/style>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<style([\\S\\s]*?)>([\\S\\s]*?)<\\\/style>', 'gmi')
const str = `<style>
.something1 {
display: flex;
color: red;
}
.something2 { display: flex; }
</style>
<div>cat</div>
<style>
.something3 {
display: flex;
color: red;
}
.something4 { display: flex; }
</style>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}