// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)<style([\S\s]*?)>([\S\s]*?)<\/style>").unwrap();
let string = "<style>
.something1 {
display: flex;
color: red;
}
.something2 { display: flex; }
</style>
<div>cat</div>
<style>
.something3 {
display: flex;
color: red;
}
.something4 { display: flex; }
</style>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}