use strict;
my $str = '[ choice A | choice B ] and choose between [ choice D | choice F ]';
my $regex = qr/\[\s*([^][|]*?)\s*\|[^][]*]/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";