import re
regex = re.compile(r"\[\s*([^][|]*?)\s*\|[^][]*]", flags=re.MULTILINE)
test_str = "[ choice A | choice B ] and choose between [ choice D | choice F ]"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)