re = /\[\s*([^][|]*?)\s*\|[^][]*]/m
str = '[ choice A | choice B ] and choose between [ choice D | choice F ]'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result