$re = '/\[\s*([^][|]*?)\s*\|[^][]*]/m';
$str = '[ choice A | choice B ] and choose between [ choice D | choice F ]';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;