// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\s*([^][|]*?)\s*\|[^][]*]").unwrap();
let string = "[ choice A | choice B ] and choose between [ choice D | choice F ]";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}