#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\s)[^\s]+$"
Local $sString = "[XIUREN秀人网] 2020.05.20 NO.2270 杨晨晨sugar" & @CRLF & _
"[UGIRLS尤果网] 2016.10.28 U221 杨晨晨" & @CRLF & _
"[YOUMI尤蜜荟] 媚眼传情 陈宇曦" & @CRLF & _
"[XIUREN秀人网] 2021.05.25 NO.3456 葛征 净高184cm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")