using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)[^\s]+$";
string input = @"[XIUREN秀人网] 2020.05.20 NO.2270 杨晨晨sugar
[UGIRLS尤果网] 2016.10.28 U221 杨晨晨
[YOUMI尤蜜荟] 媚眼传情 陈宇曦
[XIUREN秀人网] 2021.05.25 NO.3456 葛征 净高184cm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}