re = /(?<=\s)[^\s]+$/m
str = '[XIUREN秀人网] 2020.05.20 NO.2270 杨晨晨sugar
[UGIRLS尤果网] 2016.10.28 U221 杨晨晨
[YOUMI尤蜜荟] 媚眼传情 陈宇曦
[XIUREN秀人网] 2021.05.25 NO.3456 葛征 净高184cm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end