const regex = /(?<=\s)[^\s]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)[^\\s]+$', 'gm')
const str = `[XIUREN秀人网] 2020.05.20 NO.2270 杨晨晨sugar
[UGIRLS尤果网] 2016.10.28 U221 杨晨晨
[YOUMI尤蜜荟] 媚眼传情 陈宇曦
[XIUREN秀人网] 2021.05.25 NO.3456 葛征 净高184cm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}