# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>(?:\n|\r\n)/>/gm;t' <<< "bla;bla<ul>
<li>line one</li>
<li>line one</li>
<ul>bla
line two
line tree"