using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @">(?:\n|\r\n)";
string substitution = @">";
string input = @"bla;bla<ul>
<li>line one</li>
<li>line one</li>
<ul>bla
line two
line tree";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}