package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>(?:\n|\r\n)`)
var str = `bla;bla<ul>
<li>line one</li>
<li>line one</li>
<ul>bla
line two
line tree`
var substitution = ">"
fmt.Println(re.ReplaceAllString(str, substitution))
}