import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">(?:\\n|\\r\\n)";
final String string = "bla;bla<ul>\n"
+ "<li>line one</li>\n"
+ "<li>line one</li>\n"
+ "<ul>bla\n"
+ "line two\n"
+ "line tree";
final String subst = ">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}