using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"The policy parameter \'(.*?)\'";
string input = @"The policy parameter 'severity' does not match the expected parameter type defined in the policy definition '1f3afdf9-d0c9-4c3d-847f-89da613e70a8'. Details 'The policy parameter value does not match the JSON schema specified in the 'schema' property of the parameter definition. Validation Errors: 'Property 'Ldow' has not been defined and the schema does not allow additional properties. Path 'Ldow'.;Required properties are missing from object: Low. Path ''.'.'.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}