const regex = /The policy parameter \'(.*?)\'/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('The policy parameter \\\'(.*?)\\\'', 'mg')
const str = `The policy parameter 'severity' does not match the expected parameter type defined in the policy definition '1f3afdf9-d0c9-4c3d-847f-89da613e70a8'. Details 'The policy parameter value does not match the JSON schema specified in the 'schema' property of the parameter definition. Validation Errors: 'Property 'Ldow' has not been defined and the schema does not allow additional properties. Path 'Ldow'.;Required properties are missing from object: Low. Path ''.'.'.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}