import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "The policy parameter \\'(.*?)\\'";
final String string = "The policy parameter 'severity' does not match the expected parameter type defined in the policy definition '1f3afdf9-d0c9-4c3d-847f-89da613e70a8'. Details 'The policy parameter value does not match the JSON schema specified in the 'schema' property of the parameter definition. Validation Errors: 'Property 'Ldow' has not been defined and the schema does not allow additional properties. Path 'Ldow'.;Required properties are missing from object: Low. Path ''.'.'.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}