use strict;
my $str = 'The policy parameter \'severity\' does not match the expected parameter type defined in the policy definition \'1f3afdf9-d0c9-4c3d-847f-89da613e70a8\'. Details \'The policy parameter value does not match the JSON schema specified in the \'schema\' property of the parameter definition. Validation Errors: \'Property \'Ldow\' has not been defined and the schema does not allow additional properties. Path \'Ldow\'.;Required properties are missing from object: Low. Path \'\'.\'.\'.';
my $regex = qr/The policy parameter \'(.*?)\'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}