// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)The policy parameter \'(.*?)\'").unwrap();
let string = "The policy parameter 'severity' does not match the expected parameter type defined in the policy definition '1f3afdf9-d0c9-4c3d-847f-89da613e70a8'. Details 'The policy parameter value does not match the JSON schema specified in the 'schema' property of the parameter definition. Validation Errors: 'Property 'Ldow' has not been defined and the schema does not allow additional properties. Path 'Ldow'.;Required properties are missing from object: Low. Path ''.'.'.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}