using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*DATE \d{2}/\d{2}/\d{4}(?|""(.*)"".*|(.*))|.+";
string substitution = @"$1";
string input = @"LAW Nº 1234/1998 - DATE 01/01/1998""LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N"".
LAW Nº 1234/1998 - DATE 01/01/1998LAW TITLE HERE MAY CONTAIN 4|_|D4NUM3R!C OR P_NC7U@7|()N
something that does not match";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}